[Numpy-discussion] complex roots() segfault on Solaris 10/x86 with numpy 1.2.rc1 using python 2.5.2

Michael Abshoff michael.abshoff@googlemail....
Tue Sep 23 00:21:27 CDT 2008


David Cournapeau wrote:
> Michael Abshoff wrote:

Hi David,

>> This is python 2.5.2 build with gcc 4.2.4, numpy itself is build with 
>> "-O0", i.e. this is unlikely to be a compiler bug IMHO. This bug has 
>> been present in 1.0.4, 1.1.0 and it seems unfixed in 1.2.rc1. The numpy 
>> 1.1 test suite passed with that install, I did not run the 1.2.rc1 one 
>> yet since I do not have nose installed.
>>
>> gdb says nothing particularly helpful:
> 
> Yes, because you built python with -O0; you should add at least -g to
> the cflags, because here, you don't have debugging symbols, meaning the
> gdb won't be of much help unfortunately.
> 
> Would it be possible for you to rebuild python and numpy with debugging
> info ? 

Sorry for not being precise: Both python and numpy have been build with

OPT=-DNDEBUG -g -O0 -fwrapv -Wall -Wstrict-prototypes

i.e. "-O0" instead of "-O3". I am using ATLAS and netlib.org Lapack, so 
I will rebuild everything and run the BLAS as well as Lapack testers to 
make 100% sure everything is on working correctly. Since the above 
python is part of a Sage build and passes 99% of Sage's doctests I am 
pretty sure that ATLAS and Lapack do work, but one never knows. Since I 
am sleepy I will do all that tomorrow.

> I tried to look into that bug, but I can't reproduce it on
> opensolaris with gcc and python 2.4

Ok. Which compiler did you use?

> cheers,
> 
> David


Cheers,

Michael

> _______________________________________________
> Numpy-discussion mailing list
> Numpy-discussion@scipy.org
> http://projects.scipy.org/mailman/listinfo/numpy-discussion
> 



More information about the Numpy-discussion mailing list