[Numpy-discussion] python 2.4 incompatibility in numpy.lookfor in numpy 1.2.0rc2

Jarrod Millman millman@berkeley....
Tue Sep 23 15:55:56 CDT 2008


On Tue, Sep 23, 2008 at 1:35 PM, Robert Kern <robert.kern@gmail.com> wrote:
> On Tue, Sep 23, 2008 at 15:18, joep <josef.pktd@gmail.com> wrote:
>> Hi,
>> I was trying to use lookfor on python 2.4 and got an exception with
>> np.lookfor because of a missing method in pkgutil that was added in
>> python 2.5.
>
> Hmmm. Unfortunately, that's an intrinsic part of the lookfor()
> functionality. We could just bring in all of pkgutil.py. Or we remove
> lookfor(). Or we document it as working with Python 2.5 only.

For 1.2.0, let's add a note to the docstring stating it currently
works for 2.5 and make it raise a more informative exception.

lookfor is in 1.1.x as well.

-- 
Jarrod Millman
Computational Infrastructure for Research Labs
10 Giannini Hall, UC Berkeley
phone: 510.643.4014
http://cirl.berkeley.edu/


More information about the Numpy-discussion mailing list