[Numpy-discussion] trouble building docs with sphinx-0.6.1

Darren Dale dsdale24@gmail....
Wed Apr 1 11:20:38 CDT 2009


On Wed, Apr 1, 2009 at 11:57 AM, David Cournapeau <
david@ar.media.kyoto-u.ac.jp> wrote:

> Darren Dale wrote:
> > This morning I upgraded to sphinx-0.6.1, hoping to take advantage of
> > all the recent work that has been done to clean up and consolidate the
> > web of sphinx extensions. I'm seeing segfaults when I try to build my
> > own docs, or the h5py docs.
>
> Segfaults ? In sphinx or numpy related ?


I just updated my numpy svn checkout, reinstalled, and now I can build the
h5py documents without segfaulting.

> I tried building the numpy documentation after applying the attached
> > patch. After building html, updating the environment, reading sources,
> > I see a slew of warnings and errors, followed by:
> >
> > preparing documents... done
> > Exception occurred:  0%] contents
> >   File "/usr/lib64/python2.6/site-packages/docutils/nodes.py", line
> > 471, in __getitem__
> >     return self.attributes[key]
> > KeyError: 'entries'
> > The full traceback has been saved in /tmp/sphinx-err-RDe0NL.log, if
> > you want to report the issue to the author.
> > Please also report this if it was a user error, so that a better error
> > message can be provided next time.
> > Send reports to sphinx-dev@googlegroups.com
> > <mailto:sphinx-dev@googlegroups.com>. Thanks!
>
> This often happens for non-clean build. The only solution I got so far
> was to start the doc build from scratch...
>

Do you mean to delete my doc/build directory and run "make html"? I've
already tried that.

Darren
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/numpy-discussion/attachments/20090401/0231da63/attachment.html 


More information about the Numpy-discussion mailing list