[Numpy-discussion] trouble building docs with sphinx-0.6.1

Darren Dale dsdale24@gmail....
Wed Apr 1 11:44:36 CDT 2009


On Wed, Apr 1, 2009 at 12:26 PM, Pierre GM <pgmdevlist@gmail.com> wrote:

>
> On Apr 1, 2009, at 11:57 AM, David Cournapeau wrote:
> >>
> >> preparing documents... done
> >> Exception occurred:  0%] contents
> >>  File "/usr/lib64/python2.6/site-packages/docutils/nodes.py", line
> >> 471, in __getitem__
> >>    return self.attributes[key]
> >> KeyError: 'entries'
> >> The full traceback has been saved in /tmp/sphinx-err-RDe0NL.log, if
> >> you want to report the issue to the author.
> >> Please also report this if it was a user error, so that a better
> >> error
> >> message can be provided next time.
> >> Send reports to sphinx-dev@googlegroups.com
> >> <mailto:sphinx-dev@googlegroups.com>. Thanks!
> >
> > This often happens for non-clean build. The only solution I got so far
> > was to start the doc build from scratch...
>
> David, won't work here, there's a bug indeed.
> Part of it comes from numpydoc, that isn't completely compatible w/
> Sphin-0.6.1. In particular, the code doesn't know what to do w/ this
> 'entries' parameter.
> part of it comes from Sphinx. Georg said he made the 'entries'
> parameter optional, but that doesn't solve everything. Matt Knox
> actually came across the 'best' solution
> Edit Sphinx/environment.py, L1051:
> replace
> refs = [(e[0], str(e[1])) for e in toctreenode['entries'])]
> by
> refs = [(e[0], str(e[1])) for e in toctreenode.get('entries', [])]
>

Thanks Pierre, I think that did it.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/numpy-discussion/attachments/20090401/947e552e/attachment.html 


More information about the Numpy-discussion mailing list