[Numpy-discussion] [Announce] Numpy 1.3.0 rc1

Tommy Grav tgrav@mac....
Wed Apr 1 10:59:00 CDT 2009


On Mar 30, 2009, at 2:56 AM, David Cournapeau wrote:

> On Mon, Mar 30, 2009 at 3:36 AM, Robert Pyle  
> <rpyle@post.harvard.edu> wrote:
>
>>
>> I just installed 2.5.4 from python.org, and the OS X installer still
>> doesn't work.  This is on a PPC G5; I haven't tried it on my Intel
>> MacBook Pro.
>
> I think I got it. To build numpy, I use virtualenv to make a
> "bootstrap" environment, but then the corresponding python path get
> embedded in the .mpkg - so unless you have your python interpreter in
> exactly the same path as my bootstrap (which is very unlikely), it
> won't run at all. This would also explain why I never saw the problem.
>
This is exactly the problem. This is the error message that you get
when running the .dmg and no hard drives are available for selection.

You cannot install numpy 1.3.0rc1 on this volume.
  numpy requires /Users/david/src/dsp/numpy/1.3.x/bootstrap Python 2.5  
to install.


> I will prepare a new binary,

Any idea when a new binary will be available on sourceforge.net?

Cheers
Tommy


More information about the Numpy-discussion mailing list