[Numpy-discussion] trouble building docs with sphinx-0.6.1

Pauli Virtanen pav@iki...
Wed Apr 1 15:40:15 CDT 2009


Wed, 01 Apr 2009 11:48:59 -0400, Darren Dale wrote:
> This morning I upgraded to sphinx-0.6.1, hoping to take advantage of all
> the recent work that has been done to clean up and consolidate the web
> of sphinx extensions. I'm seeing segfaults when I try to build my own
> docs, or the h5py docs. I tried building the numpy documentation after
> applying the attached patch. After building html, updating the
> environment, reading sources, I see a slew of warnings and errors,
> followed by:
[clip]

It was an incompatibility of Numpy's autosummary extension and 
Sphinx >= 0.6. It should now be fixed in Numpy trunk.

-- 
Pauli Virtanen



More information about the Numpy-discussion mailing list