[Numpy-discussion] [ANN] Numpy 1.3.0rc2

Robert Pyle rpyle@post.harvard....
Fri Apr 3 11:44:09 CDT 2009


Hi David,

On Apr 3, 2009, at 11:18 AM, David Cournapeau wrote:
>
> I am pleased to announce the release of the rc2 for numpy 1.3.0. I  
> have
> decided to go for a rc2 instead of the release directly because of the
> serious mac os X issue. You can find source tarballs and installers  
> for
> both Mac OS X and Windows on the sourceforge page:
>
> https://sourceforge.net/projects/numpy/

PPC G5, Mac OS X 10.5.6

Installing from source for my usual python (EPD Py25 4.1.30101) went  
smoothly and numpy.test() passed.

Installing from the OS X installer for python.org was uneventful, but  
when I tried to run the usual tests, I got

------------------------------------------------
~ $ /Library/Frameworks/Python.framework/Versions/2.5/bin/python2.5
Python 2.5.4 (r254:67917, Dec 23 2008, 14:57:27)
[GCC 4.0.1 (Apple Computer, Inc. build 5363)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
 >>> import numpy as np
 >>> np.__version__
'1.3.0rc2'
 >>> np.test()
Running unit tests for numpy
Traceback (most recent call last):
   File "<stdin>", line 1, in <module>
   File "/Library/Frameworks/Python.framework/Versions/2.5/lib/ 
python2.5/site-packages/numpy/testing/nosetester.py", line 242, in test
     self._show_system_info()
   File "/Library/Frameworks/Python.framework/Versions/2.5/lib/ 
python2.5/site-packages/numpy/testing/nosetester.py", line 149, in  
_show_system_info
     nose = import_nose()
   File "/Library/Frameworks/Python.framework/Versions/2.5/lib/ 
python2.5/site-packages/numpy/testing/nosetester.py", line 49, in  
import_nose
     raise ImportError(msg)
ImportError: Need nose >= 0.10.0 for tests - see http://somethingaboutorange.com/mrl/projects/nose
 >>>
------------------------------------------------

I guess EPD python already has nose, but python.org does not?

Bob




More information about the Numpy-discussion mailing list