[Numpy-discussion] Blas / lapack / binary installers...

David Cournapeau david@ar.media.kyoto-u.ac...
Thu Apr 9 00:14:44 CDT 2009


Matthew Brett wrote:
>
> Yes it does...
>   

Ok.

> Yes, I know, hence my suggestion of something more practical in the
> short term.  I wonder whether the installer could be:
>
> by default, smallish, with just numpy, with the option of pulling down
> the lapack libraries from the web on installation or, possibly
> optionally, large, with the lapack libraries installed by default.
>   

That's possible, but I don't know how much work it would be to make it
work well. In particular, once you start using the web, you have all
kind of problems with proxy and the likes. But the nsis installer
certainly can support this:

http://nsis.sourceforge.net/NSISdl_plug-in

I would prefer that to a developer version, to avoid people having to
choose which version they want.

cheers,

David


More information about the Numpy-discussion mailing list