[Numpy-discussion] Numpy 1.3 on AMD64 import error

Bruce Southey bsouthey@gmail....
Thu Apr 9 11:34:47 CDT 2009


Hi,
I can not import numpy 1.3 on AMD64 on Windows Vista 64 business but
it does import with the numpy-1.3.0b1. I get the first error below
either via the command line or using IDLE. The second error occurs in
IDLE if I try a second time to import numpy but probably not
important.


Bruce

>>> import numpy

Warning (from warnings module):
  File "C:\Python26\lib\site-packages\numpy\core\__init__.py", line 5
    import multiarray
Warning: Windows 64 bits support is experimental, and only available for
testing. You are advised not to use it for production.

CRASHES ARE TO BE EXPECTED - PLEASE REPORT THEM TO NUMPY DEVELOPERS

Traceback (most recent call last):
  File "<pyshell#1>", line 1, in <module>
    import numpy
  File "C:\Python26\lib\site-packages\numpy\__init__.py", line 130, in <module>
    import add_newdocs
  File "C:\Python26\lib\site-packages\numpy\add_newdocs.py", line 9, in <module>
    from lib import add_newdoc
  File "C:\Python26\lib\site-packages\numpy\lib\__init__.py", line 13,
in <module>
    from polynomial import *
  File "C:\Python26\lib\site-packages\numpy\lib\polynomial.py", line
18, in <module>
    from numpy.linalg import eigvals, lstsq
  File "C:\Python26\lib\site-packages\numpy\linalg\__init__.py", line
47, in <module>
    from linalg import *
  File "C:\Python26\lib\site-packages\numpy\linalg\linalg.py", line
22, in <module>
    from numpy.linalg import lapack_lite
ImportError: DLL load failed: The specified module could not be found.
>>> import numpy

Traceback (most recent call last):
  File "<pyshell#2>", line 1, in <module>
    import numpy
  File "C:\Python26\lib\site-packages\numpy\__init__.py", line 130, in <module>
    import add_newdocs
  File "C:\Python26\lib\site-packages\numpy\add_newdocs.py", line 9, in <module>
    from lib import add_newdoc
  File "C:\Python26\lib\site-packages\numpy\lib\__init__.py", line 13,
in <module>
    from polynomial import *
  File "C:\Python26\lib\site-packages\numpy\lib\polynomial.py", line
11, in <module>
    import numpy.core.numeric as NX
AttributeError: 'module' object has no attribute 'core'


More information about the Numpy-discussion mailing list