[Numpy-discussion] Test failures r7300

David Cournapeau cournape@gmail....
Sat Aug 8 08:45:56 CDT 2009


On Sat, Aug 8, 2009 at 10:33 PM, <lukshuntim@gmail.com> wrote:
> David Cournapeau wrote:
>> On Sat, Aug 8, 2009 at 9:38 PM, <lukshuntim@gmail.com> wrote:
>>> Hi,
>>>
>>> I got 16 test failures after building r7300 from svn on debian/sid/i386.
>>> Seems all related to complex linear algebra modules.
>>
>> Are you using atlas ? (numpy.show_config() output)
>
> Yes, it's libatlas-sse2 3.6.0-24 debian/sid package.

I wonder if debian atlas package has the same problem as on recent Ubuntu.

> [DEFAULT]
> library_dirs = /usr/lib/sse2
> [blas_opt]
> libraries = f77blas, cblas, atlas
> [lapack_opt]
> libraries = lapack_atlas, f77blas, cblas, atlas
>
> but it seems not to pick up the liblapack_atlas.so from the debian atlas
> package.

there is no need to do this I think: it should work out of the box
without any site.cfg (the point is that it would make it easier to
change which atlas is loaded at runtime for further debugging of the
issue).

>
> Does the numpy.show_config() show that the debian atlas libaries are
> compiled with f77?

No, the f77 refers to the fortran 77 dialect, not the compiler.

What I would try is first install libatlas-base (or whatever it is
called on sid), i.e. the non sse version, and compare test output with
both sse2/nosse (e.g. using LD_LIBRARY_PATH to point to /usr/lib so
that the nosse is loaded, you can check using ldd which one is loaded
by ld).

David


More information about the NumPy-Discussion mailing list