[Numpy-discussion] Can't import numpy - problem with lapack?

Bent bbagger@gmail....
Sat Aug 15 09:14:21 CDT 2009


Hi list

I want to use Numpy with Gnuradio but I cannot make it work. The
problem, which turns out to have nothing with Gnuradio to do, is an
undefined symbol as witnessed by these messages:

bent@yosie:~> python
Python 2.6 (r26:66714, Feb  3 2009, 20:52:03)
[GCC 4.3.2 [gcc-4_3-branch revision 141291]] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import numpy
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.6/site-packages/numpy/__init__.py", line 138,
in <module>
    import linalg
  File "/usr/lib/python2.6/site-packages/numpy/linalg/__init__.py",
line 47, in <module>
    from linalg import *
  File "/usr/lib/python2.6/site-packages/numpy/linalg/linalg.py", line
29, in <module>
    from numpy.linalg import lapack_lite
ImportError: /usr/lib/python2.6/site-packages/numpy/linalg/lapack_lite.so:
undefined symbol: zgesdd_
>>> quit()
bent@yosie:~>

My distribution is openSUSE 11.1 and what really bugs me is that the
exact same setup works as expected on another PC also running openSUSE
11.1. As far as I can tell, the installed packages are exactly the
same, version numbers, build dates, etc, all are the same... The only
difference between the two PCs is that the one (the one that fails) is
a new install and the other is an upgrade from an older release.

I have googled high and low but not found anything that could bring me
further. I hope that this (collectively) all-knowledgeable list can
give me some pointers.

Kind regards,

Bent


More information about the NumPy-Discussion mailing list