[Numpy-discussion] Cython issues w/ 1.4.0

Pauli Virtanen pav+sp@iki...
Tue Dec 8 11:02:42 CST 2009


Sun, 06 Dec 2009 14:53:58 +0100, Gael Varoquaux wrote:
> I have a lot of code that has stopped working with my latest SVN pull to
> numpy.
> 
> * Some compiled code yields an error looking like (from memory):
> 
>     "incorrect type 'numpy.ndarray'"

This, by the way, also affects the 1.4.x branch. Because of the datetime 
branch merge, a new field was added to ArrayDescr -- and this breaks 
previously compiled Cython modules.

I guess this should be mentioned in the release notes. We'll probably be 
doing it again in 1.5.0...

-- 
Pauli Virtanen



More information about the NumPy-Discussion mailing list