[Numpy-discussion] Cython issues w/ 1.4.0

Gael Varoquaux gael.varoquaux@normalesup....
Tue Dec 8 11:37:36 CST 2009


On Wed, Dec 09, 2009 at 02:28:46AM +0900, David Cournapeau wrote:
> As numpy becomes more and more used as a basic for so many softwares,
> I feel like the current situation is hurting numpy users quite badly.
> Maybe I am overestimate the problem, though ?

I think you are right. It is going to hurt us pretty badly, in my
instute, where we have several python deployed, with several numpy
versions (the system one, the NFS one, and often some locally-built
packages), and users not fully aware of the situation.

In addition, it is going to make deploying soft harder, and lead to
impossible situations, where the binaries for module A work with one
version of numpy, and the binaries for module B work with another. And
recompiling is not a good option for end users.

Of course, I am not knowledgeable-enough to say technicaly what the way
out, or the best compromise is. I am just saying that the current
situation will hurt.

My 2 cents,

Gaël


More information about the NumPy-Discussion mailing list