[Numpy-discussion] Release blockers for 1.4.0 ?

David Cournapeau cournape@gmail....
Tue Dec 8 11:41:33 CST 2009


On Wed, Dec 9, 2009 at 1:21 AM, Robert Kern <robert.kern@gmail.com> wrote:

> The default has always been "print", not "warn" (except for underflow,
> which was "ignore").

Ah, ok, that explains part of the misunderstanding, sorry for the confusion.

> However, "warn" is better for the reasons you
> state (except for underflow, which should remain "ignore").

do you have an opinion on whether we should keep the current behavior
vs replacing with warn for everything but underflow for 1.4.x ?

David


More information about the NumPy-Discussion mailing list