[Numpy-discussion] [Nipy-devel] Impossibility to build nipy on recent numpy?

Pauli Virtanen pav@iki...
Thu Dec 10 07:44:34 CST 2009


to, 2009-12-10 kello 14:29 +0100, Gael Varoquaux kirjoitti:
> On Thu, Dec 10, 2009 at 05:29:07PM +0530, David Cournapeau wrote:
> > On Thu, Dec 10, 2009 at 5:13 PM, Gael Varoquaux
> > <gael.varoquaux@normalesup.org> wrote:
> 
> 
> > > Does anybody have a suggestion on how to cleanly solve the problem? I
> > > fear I won't be the only one to have it.
> 
> > The clean solution is to tell the deb package maintainer to fix the
> > packaging, and not to put numpy in /usr/include (at least, it should
> > be in /usr/include/numpy-version, like python).
> 
> OK, so your point is that numpy headers should be retrieved via 
> numpy.distutils only, right? We can probably make this argument, but it
> is going to make the life of those who use other build chains hard.

Those who need alternative build chains can locate the path to the
correct numpy headers via

        python -c 'import numpy, os; print(os.path.dirname(numpy.__file__))+"/core/include"'

which is simple to pop in e.g. in a Makefile.

I think this is a price worth paying for supporting multiple versions,
and is in any case required on non-Ubuntu platforms.

-- 
Pauli Virtanen




More information about the NumPy-Discussion mailing list