[Numpy-discussion] [ANN] numpy 1.4.0 rc2

Robert Kern robert.kern@gmail....
Mon Dec 28 11:07:28 CST 2009


On Mon, Dec 28, 2009 at 11:00, Gökhan Sever <gokhansever@gmail.com> wrote:

> One interesting thing I have noticed while installing the numpy from the
> source is that numpy dependent libraries must be re-installed and this must
> be a clean re-install. For instance I can't import some matplotlib and scipy
> modules without making a fresh installation for these packages. My attempts
> result with a runtime error.

Please, please, always copy-and-paste the traceback when reporting an
error. I know you aren't formally reporting a bug here, but it always
helps.

> Could someone clarify this point? Is this due
> to API change in the numpy core?

Cython/Pyrex code does a runtime check on the struct sizes of types.
We have carefully added a member to the PyArrayDescr struct; i.e. it
shouldn't cause any actual problems, but Cython does the check
anyways. This affects a few modules in scipy, but shouldn't have
affected anything in matplotlib. The traceback may help us identify
the issue you are seeing.

-- 
Robert Kern

"I have come to believe that the whole world is an enigma, a harmless
enigma that is made terrible by our own mad attempt to interpret it as
though it had an underlying truth."
  -- Umberto Eco


More information about the NumPy-Discussion mailing list