[Numpy-discussion] porting NumPy to Python 3

James Watson watson.jim@gmail....
Tue Feb 10 06:08:16 CST 2009


I'm taking Chuck and Bruce's suggestions and making sure that the
changes are compatible with Python 2.4 and 2.6.

I want to make sure diffs are against latest code, but keep getting
this svn error:
svn update
svn: OPTIONS of 'http://scipy.org/svn/numpy/trunk': Could not read
status line: Connection reset by peer (http://scipy.org)

Am I doing something wrong, or is the server temporarily down?

James.



>>     To get 2to3 to run without warnings, the following files require
>>     minor changes:
>>     - numpy/distutils/fcompiler/intel.py
>>     - numpy/distutils/misc_util.py
>>     - numpy/distutils/command/build_src.py
>>     - numpy/f2py/crackfortran.py
>>     - numpy/lib/function_base.py
>>     - numpy/linalg/lapack_lite/make_lite.py
>>



>>
> If you follow Guido's recommendation (at the bottom of
> http://docs.python.org/dev/3.0/whatsnew/3.0.html), then we should first
> be compatible with Python 2.6 (about the current stage) . Then
> compatible using Python 2.3 with the -3 flag (warn about Python 3.x
> incompatibilities) and fix warnings like:
>  numpy/core/__init__.py:11: DeprecationWarning: the cPickle module has
> been removed in Python 3.0
> (Of course you lose speed of cPickle if you blindly change it to use the
> old Pickle in Python 2.x)
>
> Finally use the 2to3 tool to get a Python 3 version.
>
> Bruce
>
>
> _______________________________________________
> Numpy-discussion mailing list
> Numpy-discussion@scipy.org
> http://projects.scipy.org/mailman/listinfo/numpy-discussion
>


More information about the Numpy-discussion mailing list