[Numpy-discussion] Build with MKL on linux

Gregor Thalhammer gregor.thalhammer@gmail....
Fri Feb 20 06:15:18 CST 2009


Neal Becker schrieb:
> Trying to build numpy-1.2.1 with intel mkl 10.1.1.019 on linux F10 x86_64.
>
> echo $LD_LIBRARY_PATH
> /opt/intel/mkl/10.1.1.019/lib/em64t
>
>
> strace -e trace=file python -c 'import numpy; numpy.test()' 2>stuff
> Running unit tests for numpy
> NumPy version 1.2.1
> NumPy is installed in /usr/lib64/python2.5/site-packages/numpy
> Python version 2.5.2 (r252:60911, Sep 30 2008, 15:42:03) [GCC 4.3.2 20080917
> (Red Hat 4.3.2-4)]
> nose version 0.10.3
>
> MKL FATAL ERROR: Cannot load neither libmkl_mc.so nor libmkl_def.so
>
> strace shows:
> ...
> open("/usr/lib64/python2.5/site-packages/numpy/core/tests/test_blasdot.py",
> O_RDONLY) = 3
> open("/usr/lib64/python2.5/site-packages/numpy/core/tests/test_blasdot.pyc",
> O_RDONLY) = 5
> open("/opt/intel/mkl/10.1.1.019/lib/em64t/libmkl_mc.so", O_RDONLY) = 3
> open("/opt/intel/mkl/10.1.1.019/lib/em64t/libmkl_mc.so", O_RDONLY) = 3
> open("/opt/intel/mkl/10.1.1.019/lib/em64t/libmkl_def.so", O_RDONLY) = 3
> open("/opt/intel/mkl/10.1.1.019/lib/em64t/libmkl_def.so", O_RDONLY) = 3
>
> The files are there and found, what could be wrong?
>
>   
Try MKL version 10.0.2.018. Some more information about this problem you 
find on 
http://software.intel.com/en-us/forums/intel-math-kernel-library/topic/60460/

Gregor


More information about the Numpy-discussion mailing list