[Numpy-discussion] Call for testing: full blas/lapack builds of numpy on windows 64 bits

David Cournapeau cournape@gmail....
Sat Feb 28 12:57:39 CST 2009


On Sat, Feb 28, 2009 at 7:01 AM, Bruce Southey <bsouthey@gmail.com> wrote:

> Hi,
> After much frustration and disabling my antivirus software (McAfee), I
> was able to get the 'import numpy' to work and tests to pass as
> expected. Of course after turning it back on and restarting the IDLE gui
> a few times, the 'import numpy' crashes. This also happens on the
> command line.

Hm, let's assume this is a problem of the anti virus software, and not
from mingw :) One way to test this would be to see if a binary built
with VS 2008 would cause the same trouble.

>
> This is clearly related to the antivirus software because enabling or
> disabling the 'on-access scan' is usually sufficient to failure import
> failure or success, respectively. Perhaps some thing to do with MinGW on
> Vista?

Do you have this problem only with numpy ? I noticed those kind of
crashes (right at import time) on my server 2008, but I really could
not understand what was wrong - it crashes half of the time, and when
it does not, it works perfectly (I could run the test suite 10 times
without crash). Maybe some file-related failures and runtimes
incompatibilities. There are so many combinations on windows which can
influence this that I am perfectly fine with saying that Windows + AV
is not supported:)

David


More information about the Numpy-discussion mailing list