[Numpy-discussion] When building with --prefix /usr/local numpy not detected by python

Chris Colbert sccolbert@gmail....
Mon Jun 1 15:48:32 CDT 2009


building without the prefix flag works for me as well, just wondering why
this doesnt...

Chris

On Mon, Jun 1, 2009 at 4:47 PM, Skipper Seabold <jsseabold@gmail.com> wrote:

> On Mon, Jun 1, 2009 at 4:37 PM, Chris Colbert <sccolbert@gmail.com> wrote:
> > On 64-bit ubuntu 9.04 and Python 2.6, I built numpy from source against
> > atlas and lapack (everything 64bit).
> >
> > To install, I used:   sudo python setup.py install --prefix /usr/local
> >
> > but then python doesnt find the numpy module, even though it exists in
> > /usr/local/lib/python2.6/site-packages
> >
> >
> > Do I need to add a .pth file somewhere to tell python about numpy? I
> thought
> > that would be done during the install command
> >
> > Cheers!
> >
> > Chris
> >
>
> I have two similar setups (kubuntu 64 bit and ubuntu 32 bit though)
> and am able to build without the prefix flag and everything seems to
> work okay.  Install goes into the dist-packages directory and not the
> site-packages.  I'm not sure why though to be honest.
>
> Skipper
> _______________________________________________
> Numpy-discussion mailing list
> Numpy-discussion@scipy.org
> http://mail.scipy.org/mailman/listinfo/numpy-discussion
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/numpy-discussion/attachments/20090601/17e3d594/attachment-0001.html 


More information about the Numpy-discussion mailing list