[Numpy-discussion] Inquiry Regarding F2PY Windows Content

Carl, Andrew F (AS) a.carl@ngc....
Wed Jun 10 10:55:52 CDT 2009


The default finds both the g77 & gfortran compilers. The issue is that
the flags associated w/ both appear to be corrupted by the contents of
the intel fortran environmental variables (i.e. content matched, removal
of the intel system environmental variables made the problem go away),
resulting in the example problem failing. Used f2py/diagnose.py to
verify. It's just that it took about six python install/uninstall
cycles. It would be nice to enable others to avoid the problem via a
heads-up on the F2Py Windows web page.


-----Original Message-----
From: numpy-discussion-bounces@scipy.org
[mailto:numpy-discussion-bounces@scipy.org] On Behalf Of David
Cournapeau
Sent: Wednesday, June 10, 2009 8:44 AM
To: Discussion of Numerical Python
Subject: Re: [Numpy-discussion] Inquiry Regarding F2PY Windows Content

On Thu, Jun 11, 2009 at 12:30 AM, Carl, Andrew F (AS)<a.carl@ngc.com>
wrote:
>
> Then how about known combinations of version numbers for g77/gcc, 
> python, and numpy?

Any of them should work. Numpy on windows is built with g77/gcc as
available from the official MinGW installer.

>. Something on where to look to
> see whats going on would be helpful!

Something like python setup.py build_ext --fcompiler=gnu

should force to look for g77 instead of the Intel fortran compiler.

David
_______________________________________________
Numpy-discussion mailing list
Numpy-discussion@scipy.org
http://mail.scipy.org/mailman/listinfo/numpy-discussion


More information about the Numpy-discussion mailing list