[Numpy-discussion] F2PY error with G95 on Mac OS 10.5

Adam Mercer ramercer@gmail....
Wed Jun 10 15:11:35 CDT 2009


On Wed, Jun 10, 2009 at 15:04, Samir Unni<srunni@gmail.com> wrote:

> Are you sure? When I run "f2py -c --help-fcompiler", I get:
>
> List of available Fortran compilers:
>  --fcompiler=g95  G95 Fortran Compiler (0.91)
>
> G95 is the only compiler listed as available. If it can't be used,
> then what can? I would actually prefer to use GFortran, but that is
> not listed as available.

I get the following with numpy-1.3.0:

$ f2py -c --help-fcompiler
Fortran compilers found:
Compilers available for this platform, but not found:
  --fcompiler=absoft  Absoft Corp Fortran Compiler
  --fcompiler=g95     G95 Fortran Compiler
  --fcompiler=gnu     GNU Fortran 77 compiler
  --fcompiler=gnu95   GNU Fortran 95 compiler
  --fcompiler=ibm     IBM XL Fortran Compiler
  --fcompiler=intel   Intel Fortran Compiler for 32-bit apps
  --fcompiler=nag     NAGWare Fortran 95 Compiler
Compilers not available on this platform:
  --fcompiler=compaq   Compaq Fortran Compiler
  --fcompiler=hpux     HP Fortran 90 Compiler
  --fcompiler=intele   Intel Fortran Compiler for Itanium apps
  --fcompiler=intelem  Intel Fortran Compiler for EM64T-based apps
  --fcompiler=intelev  Intel Visual Fortran Compiler for Itanium apps
  --fcompiler=intelv   Intel Visual Fortran Compiler for 32-bit apps
  --fcompiler=lahey    Lahey/Fujitsu Fortran 95 Compiler
  --fcompiler=mips     MIPSpro Fortran Compiler
  --fcompiler=none     Fake Fortran compiler
  --fcompiler=pg       Portland Group Fortran Compiler
  --fcompiler=sun      Sun or Forte Fortran 95 Compiler
  --fcompiler=vast     Pacific-Sierra Research Fortran 90 Compiler
For compiler details, run 'config_fc --verbose' setup command.
$

Cheers

Adam


More information about the Numpy-discussion mailing list