[Numpy-discussion] Ready for review: PyArrayNeighIterObject, an iterator to iterate over a neighborhood in arbitrary arrays

Robert Kern robert.kern@gmail....
Sat Jun 20 19:34:32 CDT 2009


On Sat, Jun 20, 2009 at 19:31, Gael Varoquaux
<gael.varoquaux@normalesup.org> wrote:
>
> On Sat, Jun 20, 2009 at 12:08:29PM -0600, Charles R Harris wrote:
> > Since we are extending the API and bumping up the API number, I wonder
> > if we should change the python dependency to 2.6? If there are
> > otherwise no major improvements in the pipe besides bug fixes now
> > might be the time to start laying the foundations for Python 3.0
> > compatibility.
>
> What is the reasonning behind this? What would bumping Python dependency
> give us?

It will probably be difficult to port to Python 3.0 while maintaining
compatibility with Python 2.x<6. However, that is a hypothetical, and
I am strongly against bumping the Python requirement up to 2.6 until
we discover that "difficult" is actually "near-impossible".

--
Robert Kern

"I have come to believe that the whole world is an enigma, a harmless
enigma that is made terrible by our own mad attempt to interpret it as
though it had an underlying truth."
 -- Umberto Eco


More information about the Numpy-discussion mailing list