[Numpy-discussion] Ready for review: PyArrayNeighIterObject, an iterator to iterate over a neighborhood in arbitrary arrays

David Cournapeau cournape@gmail....
Sat Jun 20 23:51:31 CDT 2009


On Sun, Jun 21, 2009 at 3:08 AM, Charles R
Harris<charlesr.harris@gmail.com> wrote:

>
> Since we are extending the API and bumping up the API number, I wonder
> if we should change the python dependency to 2.6?

I think we should keep compatibility with python 2.4, it is still used
by many people, and the default python on several major distributions
(RHEL comes to mind). Moreover, python 2.5/2.6 don't bring much
advantages compared to 2.4. The only reason I can see if if that helps
for python 3.0 porting - we are too early in the process to have a
good idea on this I think (maybe supporting both python 2.* and 3.* is
practically impossible, for example, so we would need to support numpy
for python 2.* for quite a while).

> If there are
> otherwise no major improvements in the pipe besides bug fixes now
> might be the time to start laying the foundations for Python 3.0
> compatibility.

Numpy trunk has several enhancements which are minor on their own, but
would be useful for scipy 0.8.0, reusable npy_math, in particular, to
improve scipy.special.

David


More information about the Numpy-discussion mailing list