[Numpy-discussion] Plans for Numpy 1.4.0 and scipy 0.8.0

David Cournapeau david@ar.media.kyoto-u.ac...
Sun Jun 21 04:01:31 CDT 2009


(Continuing the discussion initiated in the neighborhood iterator thread)

Hi,

    I would like to gather people's opinion on what to target for numpy
1.4.0.
    - Chuck suggested to drop python < 2.6 support from now on. I am
against it without a very strong and detailed rationale, because many OS
still don't have python 2.6 (RHEL, Ubuntu LTS).
    - Even if not many new features have been implemented since 1.3.0,
there were several changes which would be quite useful (using npy_math
from numpy for scipy.special, neighborhood iterator for scipy.signal).
So releasing 1.4.0 soon would be useful so that scipy 0.8.0 could depend
on it.
    - Fixing crashes on windows 64 bits: I have not made any progress on
this. I am out of ideas on how to debug the problem, to be honest.

Are there any other features people would like to put into numpy for 1.4.0 ?

cheers,

David



More information about the Numpy-discussion mailing list