[Numpy-discussion] Plans for Numpy 1.4.0 and scipy 0.8.0

Darren Dale dsdale24@gmail....
Sun Jun 21 06:38:26 CDT 2009


On Sun, Jun 21, 2009 at 5:01 AM, David Cournapeau <
david@ar.media.kyoto-u.ac.jp> wrote:

> (Continuing the discussion initiated in the neighborhood iterator thread)
>
> Hi,
>
>    I would like to gather people's opinion on what to target for numpy
> 1.4.0.
>    - Chuck suggested to drop python < 2.6 support from now on. I am
> against it without a very strong and detailed rationale, because many OS
> still don't have python 2.6 (RHEL, Ubuntu LTS).
>    - Even if not many new features have been implemented since 1.3.0,
> there were several changes which would be quite useful (using npy_math
> from numpy for scipy.special, neighborhood iterator for scipy.signal).
> So releasing 1.4.0 soon would be useful so that scipy 0.8.0 could depend
> on it.
>    - Fixing crashes on windows 64 bits: I have not made any progress on
> this. I am out of ideas on how to debug the problem, to be honest.
>
> Are there any other features people would like to put into numpy for 1.4.0
> ?
>

I've been trying to engage the numpy developers on a proposal to enhance the
array wrapping mechanism in ufuncs. The goal is to enable suclasses of
ndarray like MaskedArray and Quantity to work with the built-in ufuncs
instead of having to reimplement them. Here is the thread:
http://www.nabble.com/suggestion-for-generalizing-numpy-functions-tt22413628.html#a22413628
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/numpy-discussion/attachments/20090621/5f3c5903/attachment.html 


More information about the Numpy-discussion mailing list