[Numpy-discussion] Plans for Numpy 1.4.0 and scipy 0.8.0

David Cournapeau cournape@gmail....
Sun Jun 21 10:34:15 CDT 2009


On Sun, Jun 21, 2009 at 11:55 PM, Darren Dale<dsdale24@gmail.com> wrote:
> On Sun, Jun 21, 2009 at 10:38 AM, John Reid <j.reid@mail.cryst.bbk.ac.uk>
> wrote:
>>
>> David Cournapeau wrote:
>> > (Continuing the discussion initiated in the neighborhood iterator
>> > thread)
>> >     - Chuck suggested to drop python < 2.6 support from now on. I am
>> > against it without a very strong and detailed rationale, because many OS
>> > still don't have python 2.6 (RHEL, Ubuntu LTS).
>>
>> I vote against dropping support for python 2.5. Personally I have no
>> incentive to upgrade to 2.6 and am very happy with 2.5.
>
> Will requiring python-2.6 help the developers port numpy to python-3?

It will help, but it is unclear whether it will be a significant help.
>From what I have seen, very few non trivial C extensions have been
ported so far, and it is not even clear to me whether it will be
possible to support both python 2.x and python 3.x at the same time
(without a huge amount of work, that is).

David


More information about the Numpy-discussion mailing list