[Numpy-discussion] MKL Path error on Cygwin after installing on windows.

Sandeep Devadas dsandie@gmail....
Tue Jun 23 08:13:44 CDT 2009


Hi,
        I got numpy working on Python under cygwin and am getting this error
.
Please let me know what to do as I am new to Python and dont know anything.

$ python
Python 2.5.2 (r252:60911, Dec  2 2008, 09:26:14)
[GCC 3.4.4 (cygming special, gdc 0.12, using dmd 0.125)] on cygwin
Type "help", "copyright", "credits" or "license" for more information.
>>> import numpy
>>> numpy.test( 10 )
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.5/site-packages/numpy/testing/nosetester.py", line
221, in test
    argv = self._test_argv(label, verbose, extra_argv)
  File "/usr/lib/python2.5/site-packages/numpy/testing/nosetester.py", line
141, in _test_argv
    raise TypeError, 'Selection label should be a string'
TypeError: Selection label should be a string

Thanks and Regards,

Sandeep.



On Tue, Jun 23, 2009 at 2:40 PM, Sandeep Devadas <dsandie@gmail.com> wrote:

> How do I install numpy for cygwin under windows?
>
>
> On Tue, Jun 23, 2009 at 2:18 PM, David Cournapeau <
> david@ar.media.kyoto-u.ac.jp> wrote:
>
>> Sandeep Devadas wrote:
>> > Hi David,
>> >
>> >   On Mon, Jun 22, 2009 at 7:03 PM, David Cournapeau
>> > <david@ar.media.kyoto-u.ac.jp <mailto:david@ar.media.kyoto-u.ac.jp>>
>> > wrote:
>> >
>> >     Hi Sandeep,
>> >
>> >     Sandeep Devadas wrote:
>> >     > Hello There,
>> >     >                 My name is Sandeep Devadas and im trying to
>> install
>> >     > numpy for python on Cygwins latest version(1.5.xx) on Windows
>> XP.I'm
>> >     > getting an error message when I follow the instructions given at
>> >     > http://www.scipy.org/Installing_SciPy/Windows
>> >
>> >     You can't build a native numpy for windows on cygwin. You need to
>> >     build
>> >     from cmd.exe and a native python (from python.org
>> >     <http://python.org/>). Note also that
>> >     building numpy with the MKL is relatively complex - we may not be
>> able
>> >     to help you to do it completely.
>> >
>> >
>> >
>> > I need to build numpy for python interpreter on cygwin.
>>
>> You can build numpy for cygwin, but not with the MKL. Numpy has no
>> prerequisite, just a C compiler (gcc from cygwin).
>>
>> cheers,
>>
>> David
>> _______________________________________________
>> Numpy-discussion mailing list
>> Numpy-discussion@scipy.org
>> http://mail.scipy.org/mailman/listinfo/numpy-discussion
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/numpy-discussion/attachments/20090623/a1a8753e/attachment-0001.html 


More information about the Numpy-discussion mailing list