[Numpy-discussion] Deprecating function_base.unique()
Mon Jun 29 16:49:47 CDT 2009
There was some discussion (e.g.
about changes to the arraysetops module to consolidate the separate
unique/non-unique functions and rename setmember1d to in1d. There's a
patch that makes these changes in ticket 1133
The patch also deprecates function_base.unique and renames
arraysetops.unique1d to arraysetops.unique as per this discussion:
Is deprecating function_base.unique the right thing to do?
Alternatively, we could deprecate unique1d and transfer its
functionality to function_base.unique, but since many of the setops
functions use unique, arraysetops seems a more natural place for it.
Does anyone have any thoughts about this?
More information about the Numpy-discussion