[Numpy-discussion] A few more questions about build doc

Pauli Virtanen pav@iki...
Fri Mar 27 17:56:23 CDT 2009


Sat, 28 Mar 2009 04:00:45 +0900, David Cournapeau wrote:
[clip]
>     - Is it ok to build the pdf doc using LANG=C ? If I run sphinx-build
> without setting LANG=C, I got some weird latex errors at the latex->pdf
> stage, which I am reluctant to track down :)

LANG=C should be ok.

>     - I modified doc/source/conf.py such as the reported numpy version
> is exactly the one used to build the doc. Am I right that building the
> numpy documentation requires numpy to be installed (for autodoc and co),
> or is this a wrong assumption ? I've realized this after the change, but
> I can of course revert it if that's a problem,

It's the correct assumption.

I thought about this too, but decided to leave it alone so that the 
version number reported in the docs would correspond to the major XX.YY 
and not the bugfix XX.YY.ZZ releases. The point was that there ought to 
be no API changes in the .ZZ, so we'd like docs for newer versions 
(possibly containing updates etc.) be labelled as compatible with all 
XX.YY. versions.

-- 
Pauli Virtanen



More information about the Numpy-discussion mailing list