[Numpy-discussion] numpy failure under Windows Vista 64 bit

Klaus Noekel Klaus.Noekel@gmx...
Tue May 19 12:07:45 CDT 2009


Today I wanted to experiment with the AMD64 version of numpy. I am using 
Windows Vista 64 bit. I downloaded and installed today's Python 2.6.2 
AMD64 and then numpy 1.3.0 AMD64. Executing "import numpy" (nothing 
else) yielded the following error message:

IDLE 2.6.2
 >>> import numpy

Warning (from warnings module):
   File "C:\Python26\lib\site-packages\numpy\core\__init__.py", line 5
     import multiarray
Warning: Windows 64 bits support is experimental, and only available for
testing. You are advised not to use it for production.

CRASHES ARE TO BE EXPECTED - PLEASE REPORT THEM TO NUMPY DEVELOPERS

Traceback (most recent call last):
   File "<pyshell#0>", line 1, in <module>
     import numpy
   File "C:\Python26\lib\site-packages\numpy\__init__.py", line 130, in 
<module>
     import add_newdocs
   File "C:\Python26\lib\site-packages\numpy\add_newdocs.py", line 9, in 
<module>
     from lib import add_newdoc
   File "C:\Python26\lib\site-packages\numpy\lib\__init__.py", line 13, 
in <module>
     from polynomial import *
   File "C:\Python26\lib\site-packages\numpy\lib\polynomial.py", line 
18, in <module>
     from numpy.linalg import eigvals, lstsq
   File "C:\Python26\lib\site-packages\numpy\linalg\__init__.py", line 
47, in <module>
     from linalg import *
   File "C:\Python26\lib\site-packages\numpy\linalg\linalg.py", line 22, 
in <module>
     from numpy.linalg import lapack_lite
ImportError: DLL load failed: Das angegebene Modul wurde nicht gefunden.

I doubt that the DLL was not physically present and rather suspect a 
dependency on some other DLL that was missing. The INSTALL.TXT 
unfortunately was not helpful. Can anybody please explain what other 
dependencies exist? Anything else I need to install?

Thanks a lot!
Klaus Noekel
Karlsruhe, Germany


More information about the Numpy-discussion mailing list