[Numpy-discussion] Beginner Needing Help with Installation

Pierre GM pgmdevlist@gmail....
Thu Nov 19 17:27:43 CST 2009


On Nov 19, 2009, at 5:41 PM, Scot Denhalter wrote:

> Pierre,
> 
> Yes, I am using the Snow Leopard OSX.  Should I be coding through the Xcode interface and not Python's IDLE shell?  

Oh no, that's not what I meant when I asked you if you had installed Xcode. It's just that you need Xcode for the C compiler. Stick with your IDLE shell, or whatever shell you prefer (I strongly advise you to use IPython...)


> You distinguish between system wide installation and user installation.  You may have seen from my post to Eric, that I found and installed .dmg downloads for numpy and matplotlib.  I have tried to figure out where these installed themselves, but I haven't found them in the user folder.  I assume they have been installed system wide.  Is this going to be a problem?

Nope. If you go the dmg way, then you're pretty much set. 

Please note that when reporting a problem (such as your dispersion_plot issue), you should try to give us more info (matplotlib version, the script that you were using, etc.)


More information about the NumPy-Discussion mailing list