[Numpy-discussion] Numpy on Python3

David Cournapeau cournape@gmail....
Mon Nov 23 00:19:26 CST 2009


On Mon, Nov 23, 2009 at 2:35 PM, Pauli Virtanen <pav@iki.fi> wrote:

> It might be nice to have this merged in at some point after 1.4.0 (after
> the most obvious glaring bugs have been fixed), so that we could perhaps
> start aiming for Python3 compatibility in Numpy 1.5.0.

One thing I have on my end is a numpy.distutils which runs under both
python 2 and 3, so that you don't have to run 2to3 everytime you make
a change.

I did not put it in the trunk because I did not want to modify
numpy.distutils for 1.4.0 at this point, but I will include the
changes as soon as I branch the trunk into 1.4.0,

David


More information about the NumPy-Discussion mailing list