[Numpy-discussion] Installing numpy under cygwin

Olivia Cheronet cheronetolivia@yahoo....
Fri Nov 27 04:11:55 CST 2009


Hi,

I have tried to remove my entire numpy directory and starting to build it again from a newly downloaded source (numpy-1.3.0.tar.gz), but it has made no difference. I still get the output below.

Thank you for the suggestions,

Olivia
...
...
...
creating build/temp.cygwin-1.5.25-i686-2.5
creating build/temp.cygwin-1.5.25-i686-2.5/build
creating build/temp.cygwin-1.5.25-i686-2.5/build/src.cygwin-1.5.25-i686-2.5
creating build/temp.cygwin-1.5.25-i686-2.5/build/src.cygwin-1.5.25-i686-2.5/numpy
creating build/temp.cygwin-1.5.25-i686-2.5/build/src.cygwin-1.5.25-i686-2.5/numpy/core
creating build/temp.cygwin-1.5.25-i686-2.5/build/src.cygwin-1.5.25-i686-2.5/numpy/core/src
compile options: '-Inumpy/core/include -Ibuild/src.cygwin-1.5.25-i686-2.5/numpy/core/include/numpy -Inumpy/core/src -Inumpy/core/include -I/usr/include/python2.5 -c'
gcc: build/src.cygwin-1.5.25-i686-2.5/numpy/core/src/npy_math.c
numpy/core/src/npy_math.c.src:186: error: parse error before '/' token
numpy/core/src/npy_math.c.src:186: error: parse error before '/' token
error: Command "gcc -fno-strict-aliasing -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -Inumpy/core/include -Ibuild/src.cygwin-1.5.25-i686-2.5/numpy/core/include/numpy -Inumpy/core/src -Inumpy/core/include -I/usr/include/python2.5 -c build/src.cygwin-1.5.25-i686-2.5/numpy/core/src/npy_math.c -o build/temp.cygwin-1.5.25-i686-2.5/build/src.cygwin-1.5.25-i686-2.5/numpy/core/src/npy_math.o" failed with exit status 1



----- Original Message ----
> 
> I have just tested a fresh svn checkout, and could built numpy
> correctly on cygwin. I would suggest you update your sources, and
> build from scratch (i.e. remove the entire build directory and start
> from scratch).
> 
> David



      


More information about the NumPy-Discussion mailing list