[Numpy-discussion] NumPy SVN broken

David Cournapeau cournape@gmail....
Tue Oct 6 11:50:34 CDT 2009


On Wed, Oct 7, 2009 at 1:36 AM, Charles R Harris
<charlesr.harris@gmail.com> wrote:
>
>
> 2009/10/6 Stéfan van der Walt <stefan@sun.ac.za>
>>
>> Hi all,
>>
>> The current SVN HEAD of NumPy is broken and should not be used.
>> Extensions compiled against this version may (will) segfault.
>>
>
> Can you be more specific? I haven't had any problems running current svn
> with scipy.

The version itself is fine, but the ABI has been changed in an
incompatible way: if you have an extension built against say numpy
1.2.1, and then use a numpy built from sources after the datetime
merge, it will segfault right away. It does so for scipy and several
custom extensions. The abi breakage was found to be the datetime
merge.

David


More information about the NumPy-Discussion mailing list