[Numpy-discussion] NumPy SVN broken

David Warde-Farley dwf@cs.toronto....
Tue Oct 6 12:19:37 CDT 2009


On 6-Oct-09, at 12:50 PM, David Cournapeau wrote:

> The version itself is fine, but the ABI has been changed in an
> incompatible way: if you have an extension built against say numpy
> 1.2.1, and then use a numpy built from sources after the datetime
> merge, it will segfault right away. It does so for scipy and several
> custom extensions. The abi breakage was found to be the datetime
> merge.

I experienced something similar recently with both ETS and pytables.  
Good to know finally what was going on. :)

David


More information about the NumPy-Discussion mailing list