[Numpy-discussion] numpy on Snow Leopard

Celil Rufat celil.rufat@gmail....
Wed Sep 2 17:47:47 CDT 2009


I am unable to build numpy on Snow Leopard. The error that I am getting is
shown below. It is a linking issue related to the change in the the default
behavior of gcc under Snow Leopard. Before it used to compile for the 32 bit
i386 architecture, now the default is the 64 bit x86_64 architecture.

Has anybody successfully compiled numpy for MACOSX 10.6. If so I would
appreciate if you can tell me how you fixed this issue.

Regards,
Celil ... C compiler: gcc -arch ppc -arch i386 -isysroot
/Developer/SDKs/MacOSX10.4u.sdk -fno-strict-aliasing -fno-common -dynamic
-DNDEBUG -g -O3 ... gcc: _configtest.c _configtest.c:1: warning: conflicting
types for built-in function ‘exp’ _configtest.c:1: warning: conflicting
types for built-in function ‘exp’ gcc _configtest.o -o _configtest ld:
warning: in _configtest.o, missing required architecture x86_64 in file
Undefined symbols: "_main", referenced from: start in crt1.10.6.o ld:
symbol(s) not found collect2: ld returned 1 exit status ld: warning: in
_configtest.o, missing required architecture x86_64 in file Undefined
symbols: "_main", referenced from: start in crt1.10.6.o ld: symbol(s) not
found collect2: ld returned 1 exit status failure.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/numpy-discussion/attachments/20090902/4484cadc/attachment.html 


More information about the NumPy-Discussion mailing list