[Numpy-discussion] numpy/scipy/matplotlib + 10.6 + Apple python 2.6.1

David Cournapeau cournape@gmail....
Mon Sep 7 04:13:01 CDT 2009


On Mon, Sep 7, 2009 at 6:00 PM, George Nurser<gnurser@googlemail.com> wrote:
> There are some interesting instructions on how to make this work at
> http://blog.hyperjeff.net/?p=160.
> However I'm not sure that the recommendation to rename the
> Apple-supplied version of numpy is consistent with previous advice
> I've seen on this mailing list.

I think it is best to avoid touching anything in /System. The better
solution is to install things locally, at least if you don't need to
share with several users one install.

With python 2.6, there is actually a very simple way to do so, using
the --user option of python. You install everything using the --user
option, and this will get installed into your $HOME, and python will
look there first.

Also, FFTW is not needed by scipy anymore.

cheers,

David


More information about the NumPy-Discussion mailing list