[Numpy-discussion] I want to help with a numpy python 3.1.x port

René Dudfield renesd@gmail....
Fri Sep 18 11:49:40 CDT 2009


On Fri, Sep 18, 2009 at 5:36 PM, René Dudfield <renesd@gmail.com> wrote:
> On Fri, Sep 18, 2009 at 5:33 PM, Charles R Harris
> <charlesr.harris@gmail.com> wrote:
>> Numpy relies on nose for testing. I know that there is a py3k branch for
>> nose but it doesn't look very active and I don't know its current state. Do
>> you know anything about that?
>>
>> Chuck
>
> ah, bugger.  No I don't.  I can find out though...  I'll write back
> with what I find.
>
>
> cu,
>

ok... so this is the py3k branch here...
    svn checkout http://python-nose.googlecode.com/svn/branches/py3k nose3

It does look old, as nose has since moved to mecurial from svn.
Apparently it works though... but I haven't tried it.

Here is the mailing list post from april which says it's working:
    http://groups.google.com/group/nose-users/browse_thread/thread/3463fc48bad31ee8#


btw, for python code you can run the test suite with python -3 to get
it to print warnings about python3 incompatible things used.  I think
we could use this to at least start getting python3 incompatible stuff
running on python2.6.

In fact, that's where I'll start with.


cheers,


More information about the NumPy-Discussion mailing list