[Numpy-discussion] Release candidate 3 for NumPy 1.4.1 and SciPy 0.7.2

Ralf Gommers ralf.gommers@googlemail....
Mon Apr 19 03:21:45 CDT 2010


On Mon, Apr 19, 2010 at 3:35 PM, Sebastian Haase <seb.haase@gmail.com>wrote:

> Hi,
> Congratulations. I might be unnecessarily dense - but what SciPy am I
> supposed to use with the new numpy 1.4.1 for Python 2.5? I'm surprised
> that there are no SciPy 0.7.2 binaries for Python 2.5 - is that
> technically not possible ?
>
> You're not being dense, there are no 2.5 scipy binaries. I did not succeed
in building them. The scipy 0.7 branch is so old (from Jan 2009) that it has
never been compiled on OS X 10.6, and I did not yet find a way to get it to
work. For Windows I also had problems, there it should be compiled against
numpy 1.2 while the 2.6 binaries are compiled against numpy 1.3. The
variations in numpy, python and OS just added up to make it unworkable.

I can give it another try after the final release, but first priority is to
finally release.

Cheers,
Ralf



> On Mon, Apr 19, 2010 at 6:25 AM, Ralf Gommers
> <ralf.gommers@googlemail.com> wrote:
> > Hi,
> >
> > I am pleased to announce the third release candidate of both Scipy 0.7.2
> and
> > NumPy 1.4.1. Please test, and report any problems on the NumPy or SciPy
> > list.
> >
> > Binaries, sources and release notes can be found at
> > https://sourceforge.net/projects/numpy/files/
> > https://sourceforge.net/projects/scipy/files/
> >
> >
> > Changes from RC2
> > ==============
> > SciPy: warnings about possible binary incompatibilities with numpy have
> been
> > suppressed
> > NumPy: - fixed compatibility with Python 2.7b1
> >        - marked test for complex log as a known failure
> >
> >
> > NumPy 1.4.1
> > ==========
> > The main change over 1.4.0 is that datetime support has been removed.
> This
> > fixes the binary incompatibility issues between NumPy and other libraries
> > like SciPy and Matplotlib.
> >
> > There are also a number of other bug fixes, and no new features.
> >
> > Binaries for Python 2.5 and 2.6 are available for both Windows and OS X.
> >
> >
> > SciPy 0.7.2
> > =========
> > The only change compared to 0.7.1 is that the C sources for Cython code
> have
> > been regenerated with Cython 0.12.1. This ensures that SciPy 0.7.2 will
> work
> > with NumPy 1.4.1, while also retaining backwards compatibility with NumPy
> > 1.3.0.
> >
> > Note that the 0.7.x branch was created in January 2009, so a lot of fixes
> > and new functionality in current trunk is not present in this release.
> >
> > Binaries for Python 2.6 are available for both Windows and OS X. Due to
> the
> > age of the code no binaries for Python 2.5 are available.
> >
> >
> > On behalf of the NumPy and SciPy developers,
> > Ralf
> >
> > _______________________________________________
> > NumPy-Discussion mailing list
> > NumPy-Discussion@scipy.org
> > http://mail.scipy.org/mailman/listinfo/numpy-discussion
> >
> >
> _______________________________________________
> NumPy-Discussion mailing list
> NumPy-Discussion@scipy.org
> http://mail.scipy.org/mailman/listinfo/numpy-discussion
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/numpy-discussion/attachments/20100419/67db0107/attachment.html 


More information about the NumPy-Discussion mailing list