[Numpy-discussion] Numpy compilation error

David Cournapeau cournape@gmail....
Wed Apr 21 00:30:31 CDT 2010


On Tue, Apr 20, 2010 at 10:34 AM, Christopher Barker
<Chris.Barker@noaa.gov> wrote:
>
>
> Pradeep Jha wrote:
>> Thank you so much Robert. You are awesome :) That totally the problem.
>> One more question for you. Which  are the things that you have to
>> declare in PYTHONPATH manually?
>
> I never put anything in PYTHONPATH -- if you install everything you
> need, you won't need to. When I'm using something under development, I
> use setuptools' "setup.py develop"

I don't think it is wise to advocate the use of develop for python
newcomers. It comes with issues which are difficult to track down
(stalled files for entry points which are not removed by uninstall -u,
etc...). Those are non issues for the experienced users, but a pain in
my experience for beginners.

The easy and reliable solution for non root install is PYTHONPATH for
python < 2.6 and install --user for python >= 2.6.

cheers,

David


More information about the NumPy-Discussion mailing list