[Numpy-discussion] Problems building NumPy with GotoBLAS

David david@silveregg.co...
Tue Aug 17 00:09:38 CDT 2010


On 08/17/2010 01:58 PM, ashford@whisperpc.com wrote:
> I'm having problems getting the GotoBLAS library (Nehalem optimized BLAS -
> "http://www.tacc.utexas.edu/tacc-projects/gotoblas2/") working properly under
> the Python NumPy package ("http://numpy.scipy.org/") on a quad-core Nehalem
> under FC10.
>
> The command used to build the library is:
>      make BINARY=64 USE_THREAD=1 MAX_CPU_NUMBER=4
>
> I'm limiting this to four cores, as I believe HyperThreading will slow it down
> (I've seen this happen with other scientific code).  I'll benchmark later to
> see whether or not HyperThreading helps.
>
> I built the library (it uses -fPIC), then installed it under /usr/local/lib64,
> and created the appropriate links:
>      # cp libgoto2_nehalemp-r1.13.a /usr/local/lib64
>      # cp libgoto2_nehalemp-r1.13.so /usr/local/lib64
>      # cd /usr/local/lib64
>      # ln -s libgoto2_nehalemp-r1.13.a libgoto2.a
>      # ln -s libgoto2_nehalemp-r1.13.so libgoto2.so
>      # ln -s libgoto2_nehalemp-r1.13.a libblas.a
>      # ln -s libgoto2_nehalemp-r1.13.so libblas.so

The .so are only used when linking, and not the ones used at runtime 
generally (the full version, e.g. .so.1.2.3 is). Which version exactly 
depends on your installation, but I actually advise you against doing 
those softlink. You should instead specificaly link the GOTO library to 
numpy, by customizing the site.cfg,

cheers,

David


More information about the NumPy-Discussion mailing list