[Numpy-discussion] [PATCH] gfortran under macports

Fabian Pedregosa fabian.pedregosa@inria...
Sat Dec 4 03:25:52 CST 2010


>
> Correct me if I am wrong here: If you run "(sudo) gcc_select gfortran-mp-XY", where XY are the version numbers (e.g. 45 for gfortran 4.5), you should get symbolic links for the selected gcc/gfortran version. I believe that macports should probably make this clearer, and perhaps automatically when you do a "port install gccXY", but I am not sure if this needs any patching? Again, I might be wrong on this.

Thanks! I didn't know about gcc_select.

The correct command is "sudo gcc_select mp-gcc45" which effectively
does all the symbolic links for you and works like a charm, so please
ignore my previous patch.

Cheers,

fabian


More information about the NumPy-Discussion mailing list