[Numpy-discussion] Numpy and Python3

Katharina Ingwer.Wurzel@gmx....
Sat Dec 11 13:49:04 CST 2010


I'm really sorry, but the Error is the same:

----------------------------------------------------------------------------------------
 ~/Desktop/numpy-1.5.1$ python3.1 setup.py build
Converting to Python3 via 2to3...
RefactoringTool: Skipping implicit fixer: buffer
RefactoringTool: Skipping implicit fixer: idioms
RefactoringTool: Skipping implicit fixer: set_literal
RefactoringTool: Skipping implicit fixer: ws_comma
RefactoringTool: No files need to be modified.
Running from numpy source directory.Traceback (most recent call last):
  File "setup.py", line 211, in <module>
    setup_package()
  File "setup.py", line 188, in setup_package
    from numpy.distutils.core import setup
  File
"/home/natta/Desktop/numpy-1.5.1/build/py3k/numpy/distutils/__init__.py", line 22, in <module>
    import numpy.distutils.ccompiler
  File
"/home/natta/Desktop/numpy-1.5.1/build/py3k/numpy/distutils/ccompiler.py", line 15, in <module>
    from numpy.distutils.exec_command import exec_command
  File
"/home/natta/Desktop/numpy-1.5.1/build/py3k/numpy/distutils/exec_command.py", line 58, in <module>
    from numpy.compat import open_latin1
  File
"/home/natta/Desktop/numpy-1.5.1/build/py3k/numpy/compat/__init__.py",
line 14, in <module>
    from .py3k import *
AttributeError: 'module' object has no attribute 'unicode'
----------------------------------------------------------------------------------------


I don't do if it helps. But I try to install numpy1.5.1 on python2.6 
and get this Erros:
----------------------------------------------------------------------------------------
/usr/local/lib/python2.6/site-packages/numpy-1.5.1$ python setup.py
build fcompiler=gnu95
Traceback (most recent call last):
  File "setup.py", line 25, in <module>
    import builtins as builtins
ImportError: No module named builtins
----------------------------------------------------------------------------------------

/ Ingwer





Am Samstag, den 11.12.2010, 12:06 -0700 schrieb Charles R Harris:
> 
> 
> On Sat, Dec 11, 2010 at 11:53 AM, Katharina <Ingwer.Wurzel@gmx.net>
> wrote:
>         Hi,
>         yes my build is
>         in /usr/local/lib/python3.1/site-packages/numpy-1.5.1.
>         Is't wrong?
>         
> 
> Well, let's find out ;) Move your numpy download somewhere like
> ~/numpy-1.5.1, then do
> 
> cd numpy-1.5.1
> python3.1 setup.py build
> sudo python3.1 setup.py install
> 
> You should probably also do
> 
> sudo rm -rf  /usr/local/lib/python3.1/site-packages/numpy-1.5.1 before
> the build as well as remove your local build directory. You might also
> need to change ownership of the files from root to yourself.
> 
> Chuck
> 
> 
> 
> _______________________________________________
> NumPy-Discussion mailing list
> NumPy-Discussion@scipy.org
> http://mail.scipy.org/mailman/listinfo/numpy-discussion



More information about the NumPy-Discussion mailing list