[Numpy-discussion] Removing datetime support for 1.4.x series ?

Travis Oliphant oliphant@enthought....
Tue Feb 2 18:27:57 CST 2010


On Feb 2, 2010, at 9:26 AM, Bruce Southey wrote:

> On 02/02/2010 02:11 AM, David Cournapeau wrote:
>> Hi,
>>
>> This is a follow-up of the discussion about ABI-breakage in Numpy
>> 1.4.0. To sum it up, it is caused by the new datetime support, and it
>> seems difficult to fix without removing datetime support altogether
>> for the 1.4.x series.
>>
>> Both Chuck and myself are in favor of removing the datetime  
>> altogether
>> for 1.4.x as a solution. At least in my case, it is mostly justified
>> by the report from David Huard that the current datetime support is
>> still a bit too experimental to be useful for people who rely on
>> binaries.
>>
>
> +1
>
>> Are there any objections ? I know in particular Travis was against it
>> when it was suggested, but it was not known at that time that the
>> datetime support would break the ABI (I would have been more strongly
>> against it if I knew at that time). The alternative is to just signal
>> a breakage of the ABI in NumPy 1.4.1. I would like to solve this  
>> issue
>> ASAP, as it is quite a burden for people who rely on binaries
>> (changing the ABI would at least generate a useful message instead of
>> weird failures / crashes).
>>
>> cheers,
>>
>> David
>> _______________________________________________
>>
>
> I think a warning could be provided that the ABI will change in a
> forthcoming release although there has been a lot of traffic on this
> already.

I think there are too many warnings already.  I don't think adding a  
warning about an upcoming ABI change is very useful.

-Travis

--
Travis Oliphant
Enthought Inc.
1-512-536-1057
http://www.enthought.com
oliphant@enthought.com







More information about the NumPy-Discussion mailing list