[Numpy-discussion] Removing datetime support for 1.4.x series ?

Jarrod Millman millman@berkeley....
Sun Feb 7 11:19:48 CST 2010


On Sat, Feb 6, 2010 at 7:16 PM, Travis Oliphant <oliphant@enthought.com> wrote:
> I will just work on trunk and assume that the next release will be ABI
> incompatible.   At this point I would rather call the next version 1.5
> than 2.0, though.  When the date-time work is completed, then we could
> release an ABI-compatible-with-1.5  version 2.0.    My view of the
> timeline for the 1.5 release is the end of February.

I would prefer that we follow our previously discussed, agreed upon,
and explicitly stated version numbering policy:

 * The releases will be numbered major.minor.bugfix
 * There will be no ABI changes in minor releases
 * There will be no API changes in bugfix releases

In addition to it being our policy, it is also more closely aligned
with my general expectations for any mature open source project.  Just
to be clear, I would prefer to see the ABI-breaking release be called
2.0.  I don't see why we have to get the release out in three weeks,
though.  I think it would be better to use this opportunity to take
some time to make sure we get it right.  I am not suggesting that we
delay for months.  Instead, why don't we agree to consider
ABI-breakage for to 2-3 weeks.  Then close the discussion and try to
get the 2.0 release out as quickly after that as possible.

-- 
Jarrod Millman
Helen Wills Neuroscience Institute
10 Giannini Hall, UC Berkeley
http://cirl.berkeley.edu/


More information about the NumPy-Discussion mailing list