[Numpy-discussion] Removing datetime support for 1.4.x series ?

Stéfan van der Walt stefan@sun.ac...
Thu Feb 11 02:00:42 CST 2010


On 11 February 2010 09:52, Charles R Harris <charlesr.harris@gmail.com> wrote:
>> we don't stand much to lose by naming
>> this next ABI-breaking release 1.5.
>
> Except the accepted policy will be discarded and we will have to start all
> over again. We can't change policy on a whim and still maintain that we
> *have* a policy. We won't have one. But we can have long discussions...

Although one has been proposed, it has not been strictly implemented
otherwise this problem wouldn't exist.

> "...this should be purely technical IMO. There are well established rules
> here:"
>
> Simple, eh. The version should be 2.0.

I'm going with the element of least surprise: no one will be surprised
when 1.5 is released with ABI changes (it's been done that way for a
long time), but they will be surprised to see that 2.0 is not the Big
Thing it was promised to be.

Nothing we can't fix with some good PR, though :)

Cheers
Stéfan


More information about the NumPy-Discussion mailing list