[Numpy-discussion] Removing datetime support for 1.4.x series ?

David Cournapeau cournape@gmail....
Thu Feb 11 16:50:38 CST 2010


On Fri, Feb 12, 2010 at 7:38 AM, Travis Oliphant <oliphant@enthought.com> wrote:

>  I don't want to go the route of marking things "experimental" which David's
> pro-1.5 vote seemed to advocate.

In that case, I prefer the new release to be marked as 2.0. There will
then be no new numpy 1.4.x, and scipy will be built against Numpy 2.0
(to avoid having multiple scipy binaries hanging around for different
versions of NumPy).

> 1) I would like the release to come out in about 3-4 weeks
> 2) I would like the release to contain all the ABI changes we think we will
> need until NumPy 3.0 when something like David's ideas are implemented which
> would need to be no sooner than 1 year from now.
> 3) The following changes to the ABI (no promise that I might not ask for
> more before the release date):

I don't think changing the ABI before a release causes any issue, so
you can put whatever change you want to put there.

cheers,

David


More information about the NumPy-Discussion mailing list