[Numpy-discussion] numpy 2.0, what else to do?

Charles R Harris charlesr.harris@gmail....
Sun Feb 14 12:51:04 CST 2010


On Sun, Feb 14, 2010 at 11:38 AM, Charles R Harris <
charlesr.harris@gmail.com> wrote:

>
>
> On Sun, Feb 14, 2010 at 11:32 AM, Pauli Virtanen <pav@iki.fi> wrote:
>
>> Charles R Harris <charlesr.harris <at> gmail.com> writes:
>> > -  if (ap1->ob_type != ap2->ob_type) {
>> > + if (Py_TYPE(ap1) != Py_TYPE(ap2)) {
>> >
>> > Pauli fixed a lot of those. Did you remove the old build directory and
>> all
>> that stuff?
>>
>> I thought I fixed all of those, but apparently missed that one. Builds
>> fine for
>> me, but maybe it didn't find Atlas on my system for some reason.
>>
>>
> There are more - grep -r ob_type numpy/* - how do you want to go about
> fixing these things?
>
>
The py3k branch doesn't compile:

numpy/core/src/multiarray/buffer.h: At top level:
numpy/core/src/multiarray/buffer.h:14: error: conflicting types for
‘_descriptor_from_pep3118_format’
numpy/core/src/multiarray/common.c:220: note: previous implicit declaration
of ‘_descriptor_from_pep3118_format’ was here

Chuck
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/numpy-discussion/attachments/20100214/d29805ea/attachment.html 


More information about the NumPy-Discussion mailing list