[Numpy-discussion] distutils problem with NumPy-1.4 & Py-2.7a3 (Snow Leopard)

Tom Loredo loredo@astro.cornell....
Tue Feb 23 13:18:56 CST 2010


Hi-

I've been testing Python-2.7a3 on Mac OS 10.6.2.  NumPy-1.4.0 will
not install; it appears something has changed within distutils that
breaks it:

$ export MACOSX_DEPLOYMENT_TARGET=10.6
$ export CFLAGS="-arch x86_64"
$ export FFLAGS="-m64"
$ export LDFLAGS="-Wall -undefined dynamic_lookup -bundle -arch x86_64"
$ time python setup.py build --fcompiler=gnu95
Running from numpy source directory.
Traceback (most recent call last):
  File "setup.py", line 187, in <module>
    setup_package()
  File "setup.py", line 155, in setup_package
    from numpy.distutils.core import setup
  File "/Volumes/System/Users/loredo/Downloads/numpy-1.4.0-OSX/numpy/distutils/__init__.py", line 6, in <module>
    import ccompiler
  File "/Volumes/System/Users/loredo/Downloads/numpy-1.4.0-OSX/numpy/distutils/ccompiler.py", line 17, in <module>
    _old_init_posix = distutils.sysconfig._init_posix
AttributeError: 'module' object has no attribute '_init_posix'

I realize NumPy makes no claim to be compatible with 2.7(alpha); I'm
reporting this as a heads-up.

-Tom

PS:  For testing purposes:  To get nose to install for 2.7a3, 
you need to use the current hg branch.  The last release 
(including the out-of-date dev branch on PyPI) is not
compatible with 2.7 changes to unittest internals.




-------------------------------------------------
This mail sent through IMP: http://horde.org/imp/


More information about the NumPy-Discussion mailing list